AVR - problemy z programowaniem



Masz problem? Zapytaj na forum elektroda.pl

Poprzedni Następny
Wiadomość
Spis treści
From: MiKe <4lanki_at_nospam_student.uci.agh.edu.pl>
Subject: AVR - problemy z programowaniem
Date: Tue, 24 Apr 2001 13:55:20 +0200


Czesc.
AVR-y sprawiaja mi problemy przy programowaniu. Ostatnio na przyklad w
sobote zaprogramowalem, ukladzik sobie chodzil. Nastepnego dnia, nic nie
zmieniajac, zaczely sie glupoty. Przewaznie odczytywaly sie bajty jakby
z adresu, tzn poczynajac od adresu 0 odczytywalem kolejne wartosci
00,01,02... tak samo w EEPROMie jak i we FLASHu. Kombinacje z kompem
(Celeron333A, LPT1 na plycie, LPT2 noname ISA), skroceniem kabla do
20cm, odsprzeganie zasilania procesora nic nie pomagalo. W pewnym
momencie, zupelnie losowym wszystko ozywa.
Czy ktos ma podobne problemy, albo ma pomysl, co jeszcze moze byc nie
tak, na co zwrocic uwage?


--
Michal Lankosz, SQ9FQQ
http://www.sq9fqq.prv.pl
e-mail: lanki_at_nospam_student.uci.agh.edu.pl
UIN: 98838616
(z adresu zwrotnego usun cyferke 4 - to zabezpieczenie przed $#_at_nospam_%
spamerami)
------------------------------------



Poprzedni Następny
Wiadomość
Spis treści
From: "Arek Karas" <karas_at_nospam_2com.pl>
Subject: Re: AVR - problemy z programowaniem
Date: Tue, 24 Apr 2001 18:56:57 +0200


to 00, 01, 02 wskazuje, ze procesor mial zalozone Lockbity - poczytaj
dokladnie w pdf-ie.

Pozdrawiam
AK

Uzytkownik "MiKe" <4lanki_at_nospam_student.uci.agh.edu.pl> napisal w wiadomosci
news:3AE569A8.5076DA8B_at_nospam_student.uci.agh.edu.pl...
Czesc.
AVR-y sprawiaja mi problemy przy programowaniu. Ostatnio na przyklad w
sobote zaprogramowalem, ukladzik sobie chodzil. Nastepnego dnia, nic nie
zmieniajac, zaczely sie glupoty. Przewaznie odczytywaly sie bajty jakby
z adresu, tzn poczynajac od adresu 0 odczytywalem kolejne wartosci
00,01,02... tak samo w EEPROMie jak i we FLASHu. Kombinacje z kompem
(Celeron333A, LPT1 na plycie, LPT2 noname ISA), skroceniem kabla do
20cm, odsprzeganie zasilania procesora nic nie pomagalo. W pewnym
momencie, zupelnie losowym wszystko ozywa.
Czy ktos ma podobne problemy, albo ma pomysl, co jeszcze moze byc nie
tak, na co zwrocic uwage?

- kabelek wg opisow z sieci (m.inn. Strona Petersa)
- program avr_isp z Atmela
- AT90S1200

--
> Michal Lankosz, SQ9FQQ
> http://www.sq9fqq.prv.pl
> e-mail: lanki_at_nospam_student.uci.agh.edu.pl
> UIN: 98838616
> (z adresu zwrotnego usun cyferke 4 - to zabezpieczenie przed $#_at_nospam_%
> spamerami)
> ------------------------------------
>
>



Poprzedni Następny
Wiadomość
Spis treści
From: MiKe <4lanki_at_nospam_student.uci.agh.edu.pl>
Subject: Re: AVR - problemy z programowaniem
Date: Thu, 26 Apr 2001 14:39:33 +0200


Chyba nie doszedl moj list.

Nie programuje bitow zabezpieczajacych. Okazuje sie, ze po jakichs roznych
kombinacjach, wymianach procka z podstawki itp. zaczyna dzialac i normalnie
odczytuje dokladnie ten sam program i zawartosc EEPROM. Czasem zdarza sie, ze
odczytuje zupelne smieci. Kupilem dzis nastepny (juz czwarty) procesor S1200.
Ciekawe co bedzie...
A! Sprawdzam czesto obwod zegara oscyloskopem, ale tam wydaje sie, ze jest OK.

Czy sa osoby, ktore maja dlugo stycznosc z AVRami i maja z nimi jakies
problemy, czy to tylko ja takowe mam?

--
Michal Lankosz, SQ9FQQ
http://www.sq9fqq.prv.pl
e-mail: lanki_at_nospam_student.uci.agh.edu.pl
UIN: 98838616
(z adresu zwrotnego usun cyferke 4 - to zabezpieczenie przed spamerami)
------------------------------------



Poprzedni Następny
Wiadomość
Spis treści
From: "Marek Lewandowski" <locust_at_nospam_priv4.onet.pl>
Subject: Re: AVR - problemy z programowaniem
Date: Thu, 26 Apr 2001 18:29:00 +0200


Uzytkownik "MiKe" <4lanki_at_nospam_student.uci.agh.edu.pl> napisal w wiadomosci
news:3AE81705.4256F6B9_at_nospam_student.uci.agh.edu.pl...
Chyba nie doszedl moj list.

Nie programuje bitow zabezpieczajacych. Okazuje sie, ze po jakichs roznych
kombinacjach, wymianach procka z podstawki itp. zaczyna dzialac i
normalnie
odczytuje dokladnie ten sam program i zawartosc EEPROM. Czasem zdarza sie,
ze
odczytuje zupelne smieci. Kupilem dzis nastepny (juz czwarty) procesor
S1200.
Ciekawe co bedzie...
A! Sprawdzam czesto obwod zegara oscyloskopem, ale tam wydaje sie, ze jest
OK.

Czy sa osoby, ktore maja dlugo stycznosc z AVRami i maja z nimi jakies
problemy, czy to tylko ja takowe mam?

To, o czym piszesz, to niestety jeden z dwóch powodów, dla których poslalem
AVR do diabla
Drugi to nastepujace zjawisko: Polczony z mostkiem H sterowal silniczkiem
jak 5 groszy. Raz na 15 minut nagle sie wieszal i zaczynal grzac. Jesli nie
starczylo refleksu -> proc do smieci. Jak mi sie skonczyly te kupione na
próbe to odeslalem ad acta. (nie myslcie sobie, ze nie kombinowalem róznych
rzezy antyzaklóceniowych itp. Ale za kazdym razem wczesniej czy pózniej
szedl latchup i za czwartym - piatym razem nie wytrzymywal proc).

--
--
Marek Lewandowski
marek.lewandowski_at_nospam_multicon.pl UIN: 10139051
http://www.callisto.krakow.pl/~twilight





Poprzedni Następny
Wiadomość
Spis treści
From: "Juliusz" <jul_at_nospam_fom.pl>
Subject: Re: AVR - problemy z programowaniem
Date: Fri, 27 Apr 2001 15:19:38 +0200



"MiKe" <4lanki_at_nospam_student.uci.agh.edu.pl> wrote in message
news:3AE81705.4256F6B9_at_nospam_student.uci.agh.edu.pl...
Chyba nie doszedl moj list.

Nie programuje bitow zabezpieczajacych. Okazuje sie, ze po jakichs roznych
kombinacjach, wymianach procka z podstawki itp. zaczyna dzialac i
normalnie
odczytuje dokladnie ten sam program i zawartosc EEPROM. Czasem zdarza sie,
ze
odczytuje zupelne smieci. Kupilem dzis nastepny (juz czwarty) procesor
S1200.
Ciekawe co bedzie...
A! Sprawdzam czesto obwod zegara oscyloskopem, ale tam wydaje sie, ze jest
OK.

Czy sa osoby, ktore maja dlugo stycznosc z AVRami i maja z nimi jakies
problemy, czy to tylko ja takowe mam?

Sluchaj, ja uzywam tysiecy roznych AVR-ow w roku i nie mam zadnych!
problemow z nimi. Moze zacznijmy od poczatku.

Jaki masz programator ? Jak robiles sam to podeslij mi schemat tego
programatora.


Juliusz




Poprzedni Następny
Wiadomość
Spis treści
From: marekm_at_nospam_amelek.gda.pl (Marek Michalkiewicz)
Subject: Re: AVR - problemy z programowaniem
Date: 27 Apr 2001 16:57:42 GMT


MiKe <4lanki_at_nospam_student.uci.agh.edu.pl> wrote:
odczytuje zupelne smieci. Kupilem dzis nastepny (juz czwarty) procesor S1200.
Ciekawe co bedzie...
A! Sprawdzam czesto obwod zegara oscyloskopem, ale tam wydaje sie, ze jest OK.

Czy sa osoby, ktore maja dlugo stycznosc z AVRami i maja z nimi jakies
problemy, czy to tylko ja takowe mam?

Trochę tego używam (ale nie AT90S1200 - głównie AT90S8535, ostatnio
ATmega163), programuję za pomocą interfejsu STK200 przez port
równoległy programem uisp, bez problemów (poza tym co w erracie).
Ale słyszałem o różnych dziwnych problemach z 1200 (np. że same
kasują się bajty identyfikujące typ kości), proponuję przejść na
2313 (zgodny pinowo).

Marek


Poprzedni Następny
Wiadomość
Spis treści
From: "czarnY" <axda_at_nospam_poczta.onet.pl>
Subject: Re: AVR - problemy z programowaniem
Date: Sat, 28 Apr 2001 08:02:54 +0200


Mam problemy z programowaniem AT90s2313, nie wiem z czego one wynikają?
Procesory z dwóch różnych serii: jeden się programuje a drugi nie.
kp