Problemy z MAX232



Masz problem? Zapytaj na forum elektroda.pl

Poprzedni Następny
Wiadomość
Spis treści
From: "Krzysztof Kucharski" <d160_at_nospam_poland.com>
Subject: Problemy z MAX232
Date: Tue, 29 May 2001 17:08:34 +0200


Witam !

Ostatnio męczę się z pewnym (zapewnie banalnym problemem...). Otóż pomimo
podania standardowego sygnału TTL na wejście MAX-a, na jego wyjściu sygnał
jest zakłócony nieporządanymi impulsami. Ten sam efekt występuje z kośćmi
ICL-a, jak i z HIN.
Ktoś mi zasugerował, aby do wejścia TTL dołączyć rónolegle pojemność około
300 pF - zmniejszenie nachylenia zboczy impulsów.
Co o tym sądzicie ? Czy macie jakieś swoje własne doświadczenia ?

Serdecznie pozdrawiam - Krzysztof Kucharski


--
http://kgr.pl Klub Garażowych Rakietników




Poprzedni Następny
Wiadomość
Spis treści
From: "Juliusz" <jul_at_nospam_fom.pl>
Subject: Re: Problemy z MAX232
Date: Tue, 29 May 2001 23:06:36 +0200



"Krzysztof Kucharski" <d160_at_nospam_poland.com> wrote in message
news:9f0quv$cca$3_at_nospam_news.tpi.pl...
Witam !

Ostatnio męczę się z pewnym (zapewnie banalnym problemem...). Otóż pomimo
podania standardowego sygnału TTL na wejście MAX-a, na jego wyjściu sygnał
jest zakłócony nieporządanymi impulsami. Ten sam efekt występuje z kośćmi
ICL-a, jak i z HIN.
Ktoś mi zasugerował, aby do wejścia TTL dołączyć rónolegle pojemność około
300 pF - zmniejszenie nachylenia zboczy impulsów.
Co o tym sądzicie ? Czy macie jakieś swoje własne doświadczenia ?

To jest uklad, ktory nie ma prawa nie dzialac. Sprawdz czy aby masz
podlaczone wszystko jak nalezy i sprawdz czy nie jest cieply, bo moze padl.

Juliusz




Poprzedni Następny
Wiadomość
Spis treści
From: "Tomasz Gumny" <tgumny_at_nospam_idn.org.pl>
Subject: Re: Problemy z MAX232
Date: Tue, 29 May 2001 23:15:17 +0200


To jest uklad, ktory nie ma prawa nie dzialac. Sprawdz czy aby masz
podlaczone wszystko jak nalezy i sprawdz czy nie jest cieply, bo moze padl.

Ja dodam:
1. sprawdz, czy podlaczyles kondensatory;
2. czy kondensatory sa o wlasciwej pojemnosci;
3. czy nie pomyliles biegunowosci kondensatorow.
TG



Poprzedni Następny
Wiadomość
Spis treści
From: "Juliusz" <jul_at_nospam_fom.pl>
Subject: Re: Problemy z MAX232
Date: Wed, 30 May 2001 00:35:58 +0200



"Tomasz Gumny" <tgumny_at_nospam_idn.org.pl> wrote in message
news:9f13it$qq8$1_at_nospam_news.tpi.pl...
To jest uklad, ktory nie ma prawa nie dzialac. Sprawdz czy aby masz
podlaczone wszystko jak nalezy i sprawdz czy nie jest cieply, bo moze
padl.

Ja dodam:
1. sprawdz, czy podlaczyles kondensatory;
2. czy kondensatory sa o wlasciwej pojemnosci;
3. czy nie pomyliles biegunowosci kondensatorow.

Powiem tak, max232 czy HIN232 jest calkowicie zimny. Jak poczujesz, ze jest
lekko cieply to mozesz go wymienic natychmiast :-) Ja niedawno spedzilem pol
dnia nad niedzialajacym rs-em w nowym urzadzonku. Dotykalem osyloskopem
wszedzie tylko nie do hin'a, bo mi nawet nie przyszlo do glowy :-) A jednak,
byl zwalony Tx w jednym buforku.

Kondensatory to daje 10u zamiast przepisowych 1u ale jakos sie tak
przyzwyczailem. Jedyna rada to wymuszac stany i badac oscyloskopem czy nawet
miernikiem.

Juliusz




Poprzedni Następny
Wiadomość
Spis treści
From: "Krzysztof Kucharski" <d160_at_nospam_poland.com>
Subject: Re: Problemy z MAX232
Date: Wed, 30 May 2001 20:11:21 +0200



Użytkownik Juliusz <jul_at_nospam_fom.pl> w wiadomości do grup dyskusyjnych
napisał:9f18b1$en4$1_at_nospam_news.tpi.pl...

[...]
Powiem tak, max232 czy HIN232 jest calkowicie zimny. Jak poczujesz, ze
jest
lekko cieply to mozesz go wymienic natychmiast :-) Ja niedawno spedzilem
pol
dnia nad niedzialajacym rs-em w nowym urzadzonku. Dotykalem osyloskopem
wszedzie tylko nie do hin'a, bo mi nawet nie przyszlo do glowy :-) A
jednak,
byl zwalony Tx w jednym buforku.

Kondensatory to daje 10u zamiast przepisowych 1u ale jakos sie tak
przyzwyczailem. Jedyna rada to wymuszac stany i badac oscyloskopem czy
nawet
miernikiem.
[...]

OK, dzięki za sugestie ! Nie omieszkam sprawdzić.
Pojemności - z reguły używałem tantalowców, wartości to 4u7 lub 10u (takie
posiadam) i nigdy nie miałem problemów. Bywało nieraz, że stosowałem
(zwłaszcza w układach robionych na kolanie :-) ) tantalowce, pochodzące z
demontażu starych płyt głównych i kart rozszerzeń do PC. Chodziło to jak
ruski czołg. A tu teraz takie g...o :-(((.

Na koniec jedno pytanie: czy w tym "zwalonym" MAXie cokolwiek było na
wyjściu owegoż TX-a, czy zero sygnału ?


Z poważaniem - Krzysztof Kucharski


--
http://kgr.pl Klub Garażowych Rakietników




Poprzedni Następny
Wiadomość
Spis treści
From: "Juliusz" <jul_at_nospam_fom.pl>
Subject: Re: Problemy z MAX232
Date: Thu, 31 May 2001 16:03:49 +0200



"Krzysztof Kucharski" <d160_at_nospam_poland.com> wrote in message
news:9f3hle$c5$4_at_nospam_news.tpi.pl...

Na koniec jedno pytanie: czy w tym "zwalonym" MAXie cokolwiek było na
wyjściu owegoż TX-a, czy zero sygnału ?

bylo chyba cos dziwnego, nie dawal ujemnych napiec, a dodatnie bylo na
poziomie 1-3V i chyba nie zawsze takie samo. Byl cieply ale lekko cieply, a
maxy nie sa cieple w ogole. I tylko jeden bufor byl zwalony tx-owy
(ttl-->rs).

Juliusz




Poprzedni Następny
Wiadomość
Spis treści
From: "Krzysztof Kucharski" <d160_at_nospam_poland.com>
Subject: Re: Problemy z MAX232
Date: Thu, 31 May 2001 20:09:04 +0200



Użytkownik Juliusz <jul_at_nospam_fom.pl> w wiadomości do grup dyskusyjnych
napisał:9f5j2k$kv8$1_at_nospam_news.tpi.pl...

[...]
Juliusz
[...]


OK, dziękuję za pomoc.
Pozdrawiam - Krzysztof Kucharski


--
http://kgr.pl Klub Garażowych Rakietników




Poprzedni Następny
Wiadomość
Spis treści
From: "Krzysztof Kucharski" <d160_at_nospam_poland.com>
Subject: Re: Problemy z MAX232
Date: Wed, 30 May 2001 20:04:42 +0200



Użytkownik Tomasz Gumny <tgumny_at_nospam_idn.org.pl> w wiadomości do grup
dyskusyjnych napisał:9f13it$qq8$1_at_nospam_news.tpi.pl...

[...]
Ja dodam:
1. sprawdz, czy podlaczyles kondensatory;
2. czy kondensatory sa o wlasciwej pojemnosci;
3. czy nie pomyliles biegunowosci kondensatorow.
[...]

-)))))))


Z poważaniem - Krzysztof Kucharski


--
http://kgr.pl Klub Garażowych Rakietników




Poprzedni Następny
Wiadomość
Spis treści
From: "Krzysztof Kucharski" <d160_at_nospam_poland.com>
Subject: Re: Problemy z MAX232
Date: Wed, 30 May 2001 20:04:01 +0200



Użytkownik Juliusz <jul_at_nospam_fom.pl> w wiadomości do grup dyskusyjnych
napisał:9f133f$otp$1_at_nospam_news.tpi.pl...

[...]
To jest uklad, ktory nie ma prawa nie dzialac. Sprawdz czy aby masz
podlaczone wszystko jak nalezy i sprawdz czy nie jest cieply, bo moze
padl.
[...]

W tym jest problem, że znam już "nieco" :-) ten układ, ale pierwszy raz coś
takiego mi się przytrafiło. Oczywiście, połączenia są OK.


Z poważaniem - Krzysztof Kucharski


--
http://kgr.pl Klub Garażowych Rakietników




Poprzedni Następny
Wiadomość
Spis treści
From: "Marek Lewandowski" <locust_at_nospam_priv4.onet.pl>
Subject: Re: Problemy z MAX232
Date: Tue, 29 May 2001 23:31:48 +0200


Użytkownik "Krzysztof Kucharski" <d160_at_nospam_poland.com> napisał w wiadomości
news:9f0quv$cca$3_at_nospam_news.tpi.pl...
Witam !

Ostatnio męczę się z pewnym (zapewnie banalnym problemem...). Otóż pomimo
podania standardowego sygnału TTL na wejście MAX-a, na jego wyjściu sygnał
jest zakłócony nieporządanymi impulsami. Ten sam efekt występuje z kośćmi
ICL-a, jak i z HIN.
Ktoś mi zasugerował, aby do wejścia TTL dołączyć rónolegle pojemność około
300 pF - zmniejszenie nachylenia zboczy impulsów.
Co o tym sądzicie ? Czy macie jakieś swoje własne doświadczenia ?

A zasilanie dobrze? On ma na 14 i 15 nóżce.

Marek Lewandowski
marek.lewandowski_at_nospam_multicon.pl UIN: 10139051
http://locust.republika.pl




Poprzedni Następny
Wiadomość
Spis treści
From: "Remigiusz Kostuch" <remolek_at_nospam_poczta.wp.pl>
Subject: Re: Problemy z MAX232
Date: Wed, 30 May 2001 16:21:12 +0200


A zasilanie dobrze? On ma na 14 i 15 nóżce.

Chyba 15 i 16.



Poprzedni Następny
Wiadomość
Spis treści
From: "Krzysztof Kucharski" <d160_at_nospam_poland.com>
Subject: Re: Problemy z MAX232
Date: Wed, 30 May 2001 20:01:28 +0200



Użytkownik Marek Lewandowski <locust_at_nospam_priv4.onet.pl> w wiadomości do grup
dyskusyjnych napisał:9f14eg$qd$1_at_nospam_news.tpi.pl...

[...]
A zasilanie dobrze? On ma na 14 i 15 nóżce.
[...]

Mylisz się. Na 16 jest Vcc, a na 15 GND


Z poważaniem - Krzysztof Kucharski


--
http://kgr.pl Klub Garażowych Rakietników








Poprzedni Następny
Wiadomość
Spis treści
From: "SpeedBit" <kula_at_nospam_polbox.com>
Subject: Re: Problemy z MAX232
Date: Thu, 31 May 2001 22:42:42 +0200



Użytkownik "Krzysztof Kucharski" <d160_at_nospam_poland.com> napisał w wiadomości
news:9f0quv$cca$3_at_nospam_news.tpi.pl...
Witam !

Ostatnio męczę się z pewnym (zapewnie banalnym problemem...). Otóż pomimo
podania standardowego sygnału TTL na wejście MAX-a, na jego wyjściu sygnał
jest zakłócony nieporządanymi impulsami. Ten sam efekt występuje z kośćmi
ICL-a, jak i z HIN.
Ktoś mi zasugerował, aby do wejścia TTL dołączyć rónolegle pojemność około
300 pF - zmniejszenie nachylenia zboczy impulsów.

Cześć
Miałem coś takiego ze scalakiem tej serii.
Powodem były wiszące nogi od strony TTL (tak zwykle bywa jak się robi
"pająka").
Podepnij WSZYSTKIE nogi od strony TTL gdziekolwiek - oczywiście sensownie
-) - byleby nie wisiały i problem zniknie.
Nie podłaczaj tych pików - według mnie mogą zrobić więcej szkody niż
pożytku.
Ja też tak próbowałem - bez efektu. Pomogło tylko to co Ci napisałem.
Pozdrowionka

SpeedBit



Poprzedni Następny
Wiadomość
Spis treści
From: "Juliusz" <jul_at_nospam_fom.pl>
Subject: Re: Problemy z MAX232
Date: Fri, 1 Jun 2001 00:03:58 +0200



"SpeedBit" <kula_at_nospam_polbox.com> wrote in message
news:9f6af7$93e$1_at_nospam_news.tpi.pl...

Użytkownik "Krzysztof Kucharski" <d160_at_nospam_poland.com> napisał w wiadomości
news:9f0quv$cca$3_at_nospam_news.tpi.pl...
Witam !

Ostatnio męczę się z pewnym (zapewnie banalnym problemem...). Otóż
pomimo
podania standardowego sygnału TTL na wejście MAX-a, na jego wyjściu
sygnał
jest zakłócony nieporządanymi impulsami. Ten sam efekt występuje z
kośćmi
ICL-a, jak i z HIN.
Ktoś mi zasugerował, aby do wejścia TTL dołączyć rónolegle pojemność
około
300 pF - zmniejszenie nachylenia zboczy impulsów.

Cześć
Miałem coś takiego ze scalakiem tej serii.
Powodem były wiszące nogi od strony TTL (tak zwykle bywa jak się robi
"pająka").

Zerknij w schemat scalaka. Wszystkie nogi czy od strony ttl czy rs sa
podciagniete wiec nie ma to znaczenia. Chyba, ze padniety scalak.

Juliusz