ATMega128



Masz problem? Zapytaj na forum elektroda.pl

Poprzedni Następny
Wiadomość
Spis treści
From: "Łukasz Romański" <o22ie_at_nospam_wp.pl>
Subject: ATMega128
Date: Mon, 12 May 2003 23:59:11 +0200


Witam

Mam podobny problem jak kilka postów niżej
Moj ATMega128 nagle zeswirował!!!
Programuje sie OK. Weryfikuje sie OK. Odczyt OK. Problem tylko ze nie
wykonuje programu.
Co może być przyczyną i jak to poprawić?

Pozdrawiam
Łukasz



========
Path: news-archive.icm.edu.pl!agh.edu.pl!news.agh.edu.pl!newsfeed.silweb.pl!newsfeed.tpinternet.pl!szmaragd.futuro.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: "Pelos" <pelos_at_nospam_pelos.pl>
Subject: Re: ATMega128
Date: Tue, 13 May 2003 09:21:48 +0200



Użytkownik "Łukasz Romański" <o22ie_at_nospam_wp.pl> napisał w wiadomości
news:b9p55b$n2c$1_at_nospam_atlantis.news.tpi.pl...
Witam

Mam podobny problem jak kilka postów niżej
Moj ATMega128 nagle zeswirował!!!
Programuje sie OK. Weryfikuje sie OK. Odczyt OK. Problem tylko ze nie
wykonuje programu.
Co może być przyczyną i jak to poprawić?

A robiles jakies poprawki ? :-)

--
Pelos
http://www.pelos.pl



========
Path: news-archive.icm.edu.pl!agh.edu.pl!news.agh.edu.pl!news.onet.pl!newsfeed.gazeta.pl!newsfeed.tpinternet.pl!atlantis.news.tpi.pl!news.tpi.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: "Łukasz Romański" <o22ie_at_nospam_wp.pl>
Subject: Re: ATMega128
Date: Tue, 13 May 2003 11:38:39 +0200


A robiles jakies poprawki ? :-)

--
> Pelos
> http://www.pelos.pl
>
>
No tak.... Zmieniłem parę rzeczy w programie ..... Write Chip ... i głucha
cisza......
teraz czymkolwiek go nie zaprogramuje - cisza ...


Pozdrawiam
Łukasz



========
Path: news-archive.icm.edu.pl!agh.edu.pl!news.agh.edu.pl!news.onet.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: "Arek Świerc" <aswierc_at_nospam_poczta.onet.pl>
Subject: Re: ATMega128
Date: Tue, 13 May 2003 22:43:35 +0200



Użytkownik "Łukasz Romański" <o22ie_at_nospam_wp.pl> napisał w wiadomości
news:b9qe4s$c25$1_at_nospam_atlantis.news.tpi.pl...
A robiles jakies poprawki ? :-)

--
> > Pelos
> > http://www.pelos.pl
> >
> >
> No tak.... Zmieniłem parę rzeczy w programie ..... Write Chip ... i głucha
> cisza......
> teraz czymkolwiek go nie zaprogramuje - cisza ...
>
>
> Pozdrawiam
> Łukasz
>
Witam,
Z tego co udało mi się już stwierdzić, to czasem w ATMega potrafią
przestawić się bity konfiguracyjne. Może tam wystarczy pogrzebać.
Najczęściej przestawia się na external RC oscilator. W tym momencie pomaga
podanie zewnętrznego sygnału zegarowego na kwarc i procek jest gotowy do
działania =da się cokolwiek w nim przestawić:)
Pozdroofka
Arek



========
Path: news-archive.icm.edu.pl!news.icm.edu.pl!newsfeed.gazeta.pl!newsfeed.tpinternet.pl!atlantis.news.tpi.pl!news.tpi.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: "Łukasz Romański" <o22ie_at_nospam_wp.pl>
Subject: Re: ATMega128
Date: Wed, 14 May 2003 00:52:14 +0200


Witam,
Z tego co udało mi się już stwierdzić, to czasem w ATMega potrafią
przestawić się bity konfiguracyjne. Może tam wystarczy pogrzebać.
Najczęściej przestawia się na external RC oscilator. W tym momencie pomaga
podanie zewnętrznego sygnału zegarowego na kwarc i procek jest gotowy do
działania =da się cokolwiek w nim przestawić:)
Pozdroofka
Arek

Moj atmega pracuje z kwarcem 14,47MHz .. programuje go przez ISP (STK200) i
zeby było smieszniej wszystkie fusebity moge ustawiac.
Sprawdziłem w dokumentacji i fusebit odpowiadajacy za taktowanie mam
ustawiony raczej dobrze czyli
external crystal/High frequency resonator.
Po zaprogramowaniu i resecie wszystkie porty wiszą w powietrzu.

Pozdrawiam
Łukasz



========
Path: news-archive.icm.edu.pl!agh.edu.pl!news.agh.edu.pl!news.onet.pl!newsfeed.gazeta.pl!newsfeed.tpinternet.pl!atlantis.news.tpi.pl!news.tpi.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: "Łukasz Romański" <o22ie_at_nospam_wp.pl>
Subject: Re: ATMega128
Date: Wed, 14 May 2003 00:54:21 +0200


Przestawiłem ten bit i oczywiscie zgodnie z przewidywaniami koniec zabawy
kompletny.



========
Path: news-archive.icm.edu.pl!news.icm.edu.pl!news.onet.pl!newsfeed.tpinternet.pl!atlantis.news.tpi.pl!news.tpi.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: "Łukasz Romański" <o22ie_at_nospam_wp.pl>
Subject: Re: ATMega128
Date: Wed, 14 May 2003 12:00:34 +0200



Użytkownik "EM" <edim123_at_nospam_poczta.onet.pl> napisał w wiadomości
news:b9sng3$g85$1_at_nospam_news.onet.pl...
Przestawiłem ten bit i oczywiscie zgodnie z przewidywaniami koniec
zabawy
kompletny.
No to teraz musisz podłaczyć zewnętrzny oscylator....
Poza tym: czy sprawdzałeś program na symulatorze? Może gdzies jest błąd,
program idzie w maliny?
Pozdr
Em

Ehhh programowałem go nawet miganie diody.... a przy czyms takim ciezko
zrobic błąd... i nic.
Zaprogramował sie owszem... a potem cisza.
Podejrzewałem uszkodzenie portów ale nawet te piny które są używane do
programowania , podczas wykonywania programu wiszą w powietrzu zamiast .




========
Path: news-archive.icm.edu.pl!news.icm.edu.pl!news.webcorp.com.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: motonit.krzys_at_nospam_poczta.NOSPAM.fm (Motonit)
Subject: Re: ATMega128
Date: Wed, 14 May 2003 12:46:10 +0000 (UTC)


Jesli program jest na 100% oki, w takim razie procek umarł ... mam 2
sztuki podobnych (tyle, że mega 103). moje zostały wykończone
elektrostatycznie(chyba) - sa bardzo czułe. Programują się, można je
odczytać, praktycznie wszystko ale programu nie wykonują.
Robiłem na ATmega wielokrotnie i jest prosta zależność jeśli
odłączysz zasilanie przy programowaniu - to dla procka już tylko
trumienka.. ;-)
Pozdrawiam wszystkich...
--
Wyslano z forum elektronicznego: https://www.elektroda.pl/rtvforum/

========
Path: news-archive.icm.edu.pl!agh.edu.pl!news.agh.edu.pl!news.onet.pl!newsfeed.tpinternet.pl!szmaragd.futuro.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: Romuald Bialy <WYTNIJ_romek_b_at_nospam_o2.pl>
Subject: Re: ATMega128
Date: Tue, 20 May 2003 10:14:08 +0200


Dnia 2003-05-14 12:00, Użytkownik Łukasz Romański napisał:
Użytkownik "EM" <edim123_at_nospam_poczta.onet.pl> napisał w wiadomości
news:b9sng3$g85$1_at_nospam_news.onet.pl...

Przestawiłem ten bit i oczywiscie zgodnie z przewidywaniami koniec

zabawy

kompletny.

No to teraz musisz podłaczyć zewnętrzny oscylator....
Poza tym: czy sprawdzałeś program na symulatorze? Może gdzies jest błąd,
program idzie w maliny?
Pozdr
Em


Ehhh programowałem go nawet miganie diody.... a przy czyms takim ciezko
zrobic błąd... i nic.
Zaprogramował sie owszem... a potem cisza.
Podejrzewałem uszkodzenie portów ale nawet te piny które są używane do
programowania , podczas wykonywania programu wiszą w powietrzu zamiast .

A moze cos Ci przywiera RESET na stałe do masy ? Jakis zewnetrzny BOD na
przyklad.

--
Pozdrawiam Romuald Bialy
E'mail: romek_b_at_nospam_o2.pl
yampp-WWW: http://www.yamppsoft.prv.pl


========
Path: news-archive.icm.edu.pl!news.icm.edu.pl!news.onet.pl!newsgate.onet.pl!niusy.onet.p

Poprzedni Następny
Wiadomość
Spis treści
From: "EM" <edim123_at_nospam_poczta.onet.pl>
Subject: Odp: ATMega128
Date: Wed, 14 May 2003 08:25:40 +0200


Przestawiłem ten bit i oczywiscie zgodnie z przewidywaniami koniec zabawy
kompletny.
No to teraz musisz podłaczyć zewnętrzny oscylator....
Poza tym: czy sprawdzałeś program na symulatorze? Może gdzies jest błąd,
program idzie w maliny?
Pozdr
Em



========
Path: news-archive.icm.edu.pl!agh.edu.pl!news.agh.edu.pl!news.onet.pl!not-for-mai

Poprzedni Następny
Wiadomość
Spis treści
From: lukbob_at_nospam_poczta.onet.pl
Subject: Re: ATMega128
Date: 15 May 2003 15:38:26 +0200


Witam

Mam podobny problem jak kilka postów niżej
Moj ATMega128 nagle zeswirował!!!
Programuje sie OK. Weryfikuje sie OK. Odczyt OK. Problem tylko ze nie
wykonuje programu.
Co może być przyczyną i jak to poprawić?

Pozdrawiam
Łukasz


Witam!
Na poczatku małe wyjaśnienie dotyczące procesorów atmela, atmega128 powstał
jako rozszerzenie procesora atmega103. Zasadnicza róznicą jest fakt, że w
atmega128 całe 128kb pamięci flash jest przewidziane na kod programu, a nie jak
to jest w atmega103 64kb! Inne różnice sa to drobiazgi (no może z wyjątkiem
bootloadera). Wyprodukowany atmega128 ustawiony jest w tryb dzialania
kompatybilny z atmega103. Z tego wzgledu sa dwie mozliwosci, program
skompilowac jak dla procesora 103 lub przestawic tzn. Extended Fuse Byte jako
0xff (bity M103C = 1 i WDTON = 1). Oczywićcie przy tej modyfikacji należy
zwrócić uwagę na bity odpowiadające za oscylator procesora, bo moze okazać się,
że potrzebny będzie zewnętrzny generator do cofnięcia tego błędu (nowy
atmega128 ustawiony jest do pracy z rezonatorem kwarcowym).
Pozdrawiam Łukasz P.

--
Wysłano z serwisu OnetNiusy: http://niusy.onet.pl

========
Path: news-archive.icm.edu.pl!agh.edu.pl!news.agh.edu.pl!news.onet.pl!newsfeed.gazeta.pl!news.astercity.net!not-for-mai