Problem zakloceniami



Masz problem? Zapytaj na forum elektroda.pl

Poprzedni Następny
Wiadomość
Spis treści
From: "Jacek Meyerhold" <jacekmey_at_nospam_poczta.onet.pl>
Subject: Problem zakloceniami
Date: Fri, 27 Oct 2000 22:41:51 +0200


Cześć!
Zmontowałem ostatnio układ, w którym AVR steruje poprzez dwa przekaźniki
RM85 silnikiem prądu stałego. Po jednym naciśnięciu przycisku silnik ma
ruszać, po drugim zatrzymać się. Niestety wygląda to to tak,. że po
naciśnięciu przycisku następuje terkotanie przekaźnika, silnik rusza i
następnie jakby się zawiesił procesor, tzn. nie reaguje na naciskanie
przycisku i jeszcze silnie się grzeje.
Czy ktoś może mi powiedzieć co się dzieje i jak to zwalczać?

--
Pozdrawiam,
Jacek Meyerhold


Poprzedni Następny
Wiadomość
Spis treści
From: Marcin Wolcendorf <wolcendo_at_nospam_free.polbox.pl>
Subject: Re: Problem zakloceniami
Date: Sat, 28 Oct 2000 08:50:29 +0200


Cześć,

Jacek Meyerhold wrote:

Czy ktoś może mi powiedzieć co się dzieje i jak to zwalczać?

Jak sterujesz przekaźnikiem, jak zabezpieczyłeś procesor przed
przepięciami, jak zrobiłeś zasilanie procesora, silnika i przekaźników, jak
wygląda układ resetu, jak daleko jest procesor od reszty?



Pozdrawiam,

Marcin.


--
'My experience is that it is hard to find software producers that aren't
fuzzy.'




Poprzedni Następny
Wiadomość
Spis treści
From: "Jacek Meyerhold" <jacekmey_at_nospam_poczta.onet.pl>
Subject: Re: Problem zakloceniami
Date: Sat, 28 Oct 2000 13:49:34 +0200



Marcin Wolcendorf napisał(a) w wiadomości:
<39FA7735.74A5CB10_at_nospam_free.polbox.pl>...
Jacek Meyerhold wrote:
Jak sterujesz przekaźnikiem, jak zabezpieczyłeś procesor przed
przepięciami, jak zrobiłeś zasilanie procesora, silnika i przekaźników, jak
wygląda układ resetu, jak daleko jest procesor od reszty?


Przekaźnikami steruję z procesora przez tranzystory. Równoległe do cewki
podłączone są diody w stronę plusa. Procesor zasilany jest napięciem +5V,
które idzie z osobnej płytki. Zasilanie silnika jest niestabilizowane
+16V/25A (ale podpięty jest silniczek od walkmana) i też idzie z osobnej
płytki. Przekażniki zasilane są z tego samego źródła co silnik. Układ resetu
zrobiony jest następująco:. Procek podpięty jest do plusa przez opornik 4.7k
i switch do masy. Dodatkowo, od pinu RST idzie kondensator 4.7n do masy i
dioda do plusa. Procesor jest praktycznie na reszcie. Tzn. jest oddalony od
najbliższego przekaźnika o 5mm.
Pozdrawiam,
Jacek Meyerhold


Poprzedni Następny
Wiadomość
Spis treści
From: "Damian" <damianos_at_nospam_box43.gnet.pl>
Subject: Re: Problem zakloceniami
Date: Sat, 28 Oct 2000 15:44:35 +0100


A może piny, które sterują przekaźnikami są ustawione jako wejścia, a nie
wyjścia. Miałem kiedyś podobne objawy w AVR.


--
Damian
damianos_at_nospam_box43.gnet.pl

Użytkownik Jacek Meyerhold <jacekmey_at_nospam_poczta.onet.pl> w wiadomości do grup
dyskusyjnych napisał:8tefd6$5eg$1_at_nospam_news.onet.pl...
>
> Marcin Wolcendorf napisał(a) w wiadomości:
> <39FA7735.74A5CB10_at_nospam_free.polbox.pl>...
> >Jacek Meyerhold wrote:
> > Jak sterujesz przekaźnikiem, jak zabezpieczyłeś procesor przed
> >przepięciami, jak zrobiłeś zasilanie procesora, silnika i przekaźników,
jak
> >wygląda układ resetu, jak daleko jest procesor od reszty?
>
>
> Przekaźnikami steruję z procesora przez tranzystory. Równoległe do cewki
> podłączone są diody w stronę plusa. Procesor zasilany jest napięciem +5V,
> które idzie z osobnej płytki. Zasilanie silnika jest niestabilizowane
> +16V/25A (ale podpięty jest silniczek od walkmana) i też idzie z osobnej
> płytki. Przekażniki zasilane są z tego samego źródła co silnik. Układ
resetu
> zrobiony jest następująco:. Procek podpięty jest do plusa przez opornik
4.7k
> i switch do masy. Dodatkowo, od pinu RST idzie kondensator 4.7n do masy i
> dioda do plusa. Procesor jest praktycznie na reszcie. Tzn. jest oddalony
od
> najbliższego przekaźnika o 5mm.
> Pozdrawiam,
> Jacek Meyerhold
>



Poprzedni Następny
Wiadomość
Spis treści
From: "Jacek Meyerhold" <jacekmey_at_nospam_poczta.onet.pl>
Subject: Re: Problem zakloceniami
Date: Sat, 28 Oct 2000 20:31:17 +0200



Damian napisał(a) w wiadomości: <8tel5d$655$1_at_nospam_news.tpi.pl>...
A może piny, które sterują przekaźnikami są ustawione jako wejścia, a nie
wyjścia. Miałem kiedyś podobne objawy w AVR.


Nie, sprawdziłem przed chwilą, piny te pracują jako wyjściowe. W dalszym
ciągu czekam na sugestie.
Pozdrawiam,
Jacek Meyerhold


Poprzedni Następny
Wiadomość
Spis treści
From: "NoName" <God_at_nospam_heaven.org>
Subject: Re: Problem zakloceniami
Date: Mon, 30 Oct 2000 12:56:04 +0100


Sprobuj podlaczyc diody swiecace zamiast przekaznikow i zobacz
czy dziala poprawnie.



Poprzedni Następny
Wiadomość
Spis treści
From: "milosz klosowicz" <mklosowicz_at_nospam_infovide.pl>
Subject: Re: Problem zakloceniami
Date: Sat, 28 Oct 2000 22:23:01 +0200



Jacek Meyerhold <jacekmey_at_nospam_poczta.onet.pl> wrote in message
news:8tcr7p$8na$1_at_nospam_news.onet.pl...
Cześć!
Zmontowałem ostatnio układ, w którym AVR steruje poprzez dwa przekaźniki
RM85 silnikiem prądu stałego. Po jednym naciśnięciu przycisku silnik ma
ruszać, po drugim zatrzymać się. Niestety wygląda to to tak,. że po
naciśnięciu przycisku następuje terkotanie przekaźnika, silnik rusza i
następnie jakby się zawiesił procesor, tzn. nie reaguje na naciskanie
przycisku i jeszcze silnie się grzeje.
Jesli ten sam przycisk wlacza i wylacza to problem moze byc w programie. Jak
wyglada procedura obslugi tego klawisza - czy są odpowiednie opóznienia
pomiędzy załączeniem silnika a ponownym odczytem przycisku w celu wyłączenia
?



Poprzedni Następny
Wiadomość
Spis treści
From: Piotr Knysak <PKnysak_at_nospam_wel.wat.waw.pl>
Subject: Re: Problem zakloceniami
Date: Mon, 30 Oct 2000 14:43:11 +0100






Jesli ten sam przycisk wlacza i wylacza to problem moze byc w programie. Jak
wyglada procedura obslugi tego klawisza - czy sš odpowiednie opóznienia
pomiędzy załšczeniem silnika a ponownym odczytem przycisku w celu wyłšczenia
?

Co z eliminacjš drgań zestyków przycisku?
Pozdrawiam
Piotr



Poprzedni Następny
Wiadomość
Spis treści
From: "Juliusz" <jul_at_nospam_fom.pl>
Subject: Re: Problem zakloceniami
Date: Mon, 30 Oct 2000 17:46:43 +0100



Piotr Knysak <PKnysak_at_nospam_wel.wat.waw.pl> wrote in message
news:39FD7AEF.F5F8C841_at_nospam_wel.wat.waw.pl...




Jesli ten sam przycisk wlacza i wylacza to problem moze byc w programie.
Jak
wyglada procedura obslugi tego klawisza - czy sš odpowiednie opóznienia
pomiędzy załšczeniem silnika a ponownym odczytem przycisku w celu
wyłšczenia
?

Co z eliminacjš drgań zestyków przycisku?
Pozdrawiam


Ja juz mu narysowalem schemat od poczatku, bo to co zastalem to ............
-((((((((((((( LOL.

Np uzywa transoptora z wyprowadzona baza i baza wisi w powietrzu :-)
100n nie istnieja dla niego :-)
A wogole to cewke przekaznika steruje z tego transoptora bezposrednio co ma
wiszaca baze :-)

Wejscia do procka steruje transoptorami tez z wiszaca baza, bez
podciagniecia jak otwarym kolektorem :-)))))))))

Zapewne ma za miekkie zasilanie, bo z tego samo trafa i prostownika zasila
elektronike i silnik, toz to mu sie w AVR'ku wlacza czujnik spadku napiecia
-)

No nie :-)))))))

Juliusz




Poprzedni Następny
Wiadomość
Spis treści
From: "Andy" <anok_at_nospam_ceti.pl>
Subject: Re: Problem zakloceniami
Date: Sun, 29 Oct 2000 01:30:58 +0200


Jacek Meyerhold napisał(a) w wiadomości: <8tcr7p$8na$1_at_nospam_news.onet.pl>...
Zmontowałem ostatnio układ, w którym AVR steruje poprzez dwa przekaźniki
RM85 silnikiem prądu stałego. Po jednym naciśnięciu przycisku silnik ma
ruszać, po drugim zatrzymać się. Niestety wygląda to to tak,. że po
naciśnięciu przycisku następuje terkotanie przekaźnika, silnik rusza i
następnie jakby się zawiesił procesor, tzn. nie reaguje na naciskanie
przycisku i jeszcze silnie się grzeje.
...

a jak zamiast przekaznika dasz zaroweczke lub leda
to jest OK czy tez sie wiesza ?

Andrzej




Poprzedni Następny
Wiadomość
Spis treści
From: "Jacek Meyerhold" <jacekmey_at_nospam_poczta.onet.pl>
Subject: Re: Problem zakloceniami
Date: Sun, 29 Oct 2000 12:14:20 +0100



Andy napisał(a) w wiadomości: <8tfnfv$3oh$1_at_nospam_news.tpi.pl>...
Jacek Meyerhold napisał(a) w wiadomości: <8tcr7p$8na$1_at_nospam_news.onet.pl>...
a jak zamiast przekaznika dasz zaroweczke lub leda
to jest OK czy tez sie wiesza ?
Z przekaźnikami mniej więcej działa, z silnikiem bezszczotkowym też, problem
następuje przy normalnym silniku.
Pozdrawiam,
Jacek Meyerhold


Poprzedni Następny
Wiadomość
Spis treści
From: "Jacek Meyerhold" <jacekmey_at_nospam_poczta.onet.pl>
Subject: Re: Problem zakloceniami
Date: Sun, 29 Oct 2000 16:48:09 +0100



Jacek Meyerhold napisał(a) w wiadomości: <8th0lr$joi$1_at_nospam_news.onet.pl>...

Andy napisał(a) w wiadomości: <8tfnfv$3oh$1_at_nospam_news.tpi.pl>...
Jacek Meyerhold napisał(a) w wiadomości: <8tcr7p$8na$1_at_nospam_news.onet.pl>...


Chyba zrobię nową płytkę.. Proszę o wskazówki jak to zrobić, żeby problem
się nie powtórzył. Transoptory, ekran ? Jakie jest prawdopodobieństwo, że
jak to zrobię to problem nie wystąpi?
Pozdrawiam,
Jacek Meyerhold


Poprzedni Następny
Wiadomość
Spis treści
From: "Juliusz" <jul_at_nospam_fom.pl>
Subject: Re: Problem zakloceniami
Date: Sun, 29 Oct 2000 17:38:34 +0100



Chyba zrobię nową płytkę.. Proszę o wskazówki jak to zrobić, żeby problem
się nie powtórzył. Transoptory, ekran ? Jakie jest prawdopodobieństwo, że
jak to zrobię to problem nie wystąpi?
Pozdrawiam,
Jacek Meyerhold


Wyslij schemat to zerkne, a no i projekt PCB tez...

Juliusz