=?ISO-8859-2?Q?modu=B3_motoroli_M12?=



Masz problem? Zapytaj na forum elektroda.pl

Poprzedni Następny
Wiadomość
Spis treści
From: tom <tom_at_nospam_w.nospamer.pl>
Subject: =?ISO-8859-2?Q?modu=B3_motoroli_M12?=
Date: Tue, 15 Nov 2005 14:29:21 +0100


Mam problem z przetestowaniem takiego modułu M12. Jedyne co udało mi
się uzyskać to położenie satelit i jakość sygnału. Cała reszta milczy
jak zaklęta. Próbowałem to robić przy użyciu programu WinOnCore. Czy
ktoś mógłby mi opisać jak powinna wyglądać sekwencja do uzyskania
położenia ewentualnie gdzie mógłbym znaleźć jakieś info, bo od kilku dni
się na tym męczę i nic, a w googlach tez nie mogę znaleźć niczego co by
rozwiązywało mój problem.
--
Pozdr.
Tom

Poprzedni Następny
Wiadomość
Spis treści
From: "Andy" <anokWYTNIJ_at_nospam_ceti.pl>
Subject: Re: moduł motoroli M12
Date: Tue, 15 Nov 2005 18:57:37 +0100


Użytkownik "tom" <tom_at_nospam_w.nospamer.pl> napisał w wiadomości
news:dlcnrr$1u4$1_at_nospam_atlantis.news.tpi.pl...
Mam problem z przetestowaniem takiego modułu M12. Jedyne co udało mi
się uzyskać to położenie satelit i jakość sygnału. Cała reszta milczy
jak zaklęta. Próbowałem to robić przy użyciu programu WinOnCore. Czy
ktoś mógłby mi opisać jak powinna wyglądać sekwencja do uzyskania
położenia ewentualnie gdzie mógłbym znaleźć jakieś info, bo od kilku dni
się na tym męczę i nic, a w googlach tez nie mogę znaleźć niczego co by
rozwiązywało mój problem.
--
> Pozdr.
> Tom

w binarnym trybie

_at_nospam__at_nospam_Hb

http://www.synergy-gps.com/Mot_Manuals.html
http://www.synergy-gps.com/M12EngNotes.pdf
http://www.synergy-gps.com/M12%20_Supplement.pdf

--
Andrzej




Poprzedni Następny
Wiadomość
Spis treści
From: tom <tom_at_nospam_w.nospamer.pl>
Subject: Re: =?ISO-8859-2?Q?modu=B3_motoroli_M12?=
Date: Thu, 17 Nov 2005 10:54:37 +0100


Andy napisał(a):
Użytkownik "tom" <tom_at_nospam_w.nospamer.pl> napisał w wiadomości
news:dlcnrr$1u4$1_at_nospam_atlantis.news.tpi.pl...

Mam problem z przetestowaniem takiego modułu M12. Jedyne co udało mi
się uzyskać to położenie satelit i jakość sygnału. Cała reszta milczy
jak zaklęta. Próbowałem to robić przy użyciu programu WinOnCore. Czy
ktoś mógłby mi opisać jak powinna wyglądać sekwencja do uzyskania
położenia ewentualnie gdzie mógłbym znaleźć jakieś info, bo od kilku dni
się na tym męczę i nic, a w googlach tez nie mogę znaleźć niczego co by
rozwiązywało mój problem.
--
>>Pozdr.
>>Tom
>
>
> w binarnym trybie
>
> _at_nospam__at_nospam_Hb
>
> http://www.synergy-gps.com/Mot_Manuals.html
> http://www.synergy-gps.com/M12EngNotes.pdf
> http://www.synergy-gps.com/M12%20_Supplement.pdf

Wielkie dzięki ale okazuje sie zrobiłem błąd podając że to moduł M12.
Jest to FSOnCore oparty o MG4100. Takie coś jak tu:
http://www.posnav.com.au/fsoncore.htm
Więc chyba będzie lepiej jak podam wszystko od początku.
Otóż moduł ten ma dwa porty UART natomiast to co ja dostałem jest
połączone z kompem tylko przez jeden. Aplikacja natomiast z której
korzystam (WinOnCore12) używa dwóch portów. Jak dotąd mogę używając tego
jednego portu załadować firmware i go uruchomić.
Wydanie komend :
_at_nospam__at_nospam_Oj00000B01FF84DFFF02FA0407bf04000017001700150015
_at_nospam__at_nospam_Oa0400050005147F00010101
_at_nospam__at_nospam_Ot010000010001
które miało spowodować pracę układu w trybie autonomicznym powoduje iż
otrzymuję dane dotyczące satelit i tylko tyle.
Część komend program wysyła używając drugiego portu, do takich komend
należy m.in _at_nospam__at_nospam_Hb, lecz nawet po podłączeniu tego drugie portu sytuacja
sie nie zmienia (nie widze żadnej aktywności modułu na tym porcie). Co
do satelit to ich dane otrzymuję tylko po podaniu w tym programie
własnego położenia. Układ widzi wtedy około 11 satelit.
Czy do poprawnej pracy potrzebny jest ten drugi port? Jeśli tak to jak
powinien być skonfigurowany. Nie wiem czy przypadkiem ten moduł nie
współpracuje z WinOncore i trzeba napisać własny soft do współpracy z nim.
--
Pozdr.
Tom


Poprzedni Następny
Wiadomość
Spis treści
From: "tomm" <tmroz1_at_nospam_poczta.gazeta.pl>
Subject: Re: moduł motoroli M12
Date: Thu, 17 Nov 2005 12:00:56 +0100


Czy do poprawnej pracy potrzebny jest ten drugi port? Jeśli tak to jak
powinien być skonfigurowany. Nie wiem czy przypadkiem ten moduł nie
współpracuje z WinOncore i trzeba napisać własny soft do współpracy z nim.

z tego co czytam to wogole on potrzebuje zaladowania
jakiego softu z zewnatrz zaraz po jego uruchomieniu

normlanie to GPS po wlaczeniu wysyla na RS od razu
dane w standardzie NEMA - ten tak widac nie dziala

Tomek




Poprzedni Następny
Wiadomość
Spis treści
From: "tomm" <tmroz1_at_nospam_poczta.gazeta.pl>
Subject: Re: moduł motoroli M12
Date: Thu, 17 Nov 2005 12:02:12 +0100



z tego co czytam to wogole on potrzebuje zaladowania
jakiego softu z zewnatrz zaraz po jego uruchomieniu

PS
zobacz to:
http://www.synergy-gps.com/FS%20Oncore%20Sample%20Implementation.pdf

256 kB na soft dla niego

Tomek



Poprzedni Następny
Wiadomość
Spis treści
From: tom <tom_at_nospam_w.nospamer.pl>
Subject: Re: =?ISO-8859-2?Q?modu=B3_motoroli_M12?=
Date: Fri, 18 Nov 2005 13:22:21 +0100


tomm napisał(a):
z tego co czytam to wogole on potrzebuje zaladowania
jakiego softu z zewnatrz zaraz po jego uruchomieniu


PS
zobacz to:
http://www.synergy-gps.com/FS%20Oncore%20Sample%20Implementation.pdf

256 kB na soft dla niego

No właśnie pisałem że ładuję do niego firware - to te 256kB softu. Tylko
nie wiem jak zmusić go by otrzymać swoje położenie. Bo po tych trzech
komendach pozycja jaką otzymuję to 0,0 a to leży tak niezbyt w polsce.
Tak samo coś jest nie tak bo otrzymuję nr tygodnia jako 1024 a z tego co
wyczytałem to jest błąd.
--
Pozdr.
Tom

Poprzedni Następny
Wiadomość
Spis treści
From: "tomm" <tmroz1_at_nospam_poczta.gazeta.pl>
Subject: Re: moduł motoroli M12
Date: Fri, 18 Nov 2005 14:08:10 +0100


No właśnie pisałem że ładuję do niego firware - to te 256kB softu. Tylko
nie wiem jak zmusić go by otrzymać swoje położenie. Bo po tych trzech
komendach pozycja jaką otzymuję to 0,0 a to leży tak niezbyt w polsce.
Tak samo coś jest nie tak bo otrzymuję nr tygodnia jako 1024 a z tego co
wyczytałem to jest błąd.

ok, a jak ta jakosc sygnalu ktora odczytujesz ??
moze cos tam nie jest w porzadku i tak na prawde
moze znalazl sygnaly od nich ale sa za slabe,
(uszkodzona antena)

moze nie jest jakos zainicjalizowany ??

tak tylko strzelam, za malo sie znam , ale moze
wlasnie jest jakis inny powod, ze nie chodzi o sekwencje
do uzystania polozenia (jak to na wstepie pisales)
ale o jakies zainicjalizowanie

Tomek



Poprzedni Następny
Wiadomość
Spis treści
From: tom <tom_at_nospam_w.nospamer.pl>
Subject: Re: =?ISO-8859-2?Q?modu=B3_motoroli_M12?=
Date: Mon, 21 Nov 2005 08:03:56 +0100


tomm napisał(a):
No właśnie pisałem że ładuję do niego firware - to te 256kB softu. Tylko
nie wiem jak zmusić go by otrzymać swoje położenie. Bo po tych trzech
komendach pozycja jaką otzymuję to 0,0 a to leży tak niezbyt w polsce.
Tak samo coś jest nie tak bo otrzymuję nr tygodnia jako 1024 a z tego co
wyczytałem to jest błąd.


ok, a jak ta jakosc sygnalu ktora odczytujesz ??
moze cos tam nie jest w porzadku i tak na prawde
moze znalazl sygnaly od nich ale sa za slabe,
(uszkodzona antena)

moze nie jest jakos zainicjalizowany ??

tak tylko strzelam, za malo sie znam , ale moze
wlasnie jest jakis inny powod, ze nie chodzi o sekwencje
do uzystania polozenia (jak to na wstepie pisales)
ale o jakies zainicjalizowanie



Jakoś sygnału w tym programie nie ma podanej jednostki, a jedynie podany
stosunek C/No co wydaje mi się być stosunkiem sygnał/szum. Wartość tego
jest na poziomie do 25 (dB?). Co do zainicjowania to być może coś trzeba
jeszcze podać bo jak wcześniej wspomniałem to układ widzi koło 11
satelit ale jak mu podam własne położenie, w przeciwnym wypadku widzi
tylko 1 i to na granicy bo ten C/No wynosi wtedy 0.
--
Pozdr.
Tom