AVR Studio4 - dziwny problem



Masz problem? Zapytaj na forum elektroda.pl

Poprzedni Następny
Wiadomość
Spis treści
From: Viki <viki_at_nospam_poczta.onet.pl>
Subject: AVR Studio4 - dziwny problem
Date: Tue, 23 May 2006 22:53:36 +0200


Witam.

Pisze sobie programik od jakiegoś czasu w tym środowisku 4.12 Build 472
SP2. Korzystam z kompilatora AVR GCC dostarczanego wraz ze środowiskiem
WinAvr. Pewnego dnia otwieram swĂłj projekt i dostaje komunikaty o
błędach: Error creating plugin.
Jak się okazało, środowisko straciło scieżki do kompilatorów assemblera
i AVR GCC. Kiedy chciałem zrobić nowy projekt nie mogłem wybrać ani ASM
ani GCC project.
Gdzie ustawia się te ścieżki bo nie moge tego odszukać.
Nie wiem właściwie co się mogło stać. Miał ktoś taki problem??
Przeinstalowałem całe środowisko i nic.

Pozdrawiam.

Poprzedni Następny
Wiadomość
Spis treści
From: "Greg\(G.Kasprowicz\)" <gkasprow_at_nospam_gmail.com>
Subject: Re: AVR Studio4 - dziwny problem
Date: Tue, 23 May 2006 23:03:45 +0200


Gdzie ustawia się te ścieżki bo nie moge tego odszukać.
system->zaawansowane->zmienne srodowiskowe



Poprzedni Następny
Wiadomość
Spis treści
From: Viki <Viki_at_nospam_wp.pl>
Subject: Re: AVR Studio4 - dziwny problem
Date: Wed, 24 May 2006 07:54:11 +0200


system->zaawansowane->zmienne srodowiskowe

Tu jest wszystko ok ale kiedy chce zrobić np. nowy projekt okienko
project type jest puste!
normalnie moge tam wybrać AVR assembler lub AVR gcc.
Jak mówię reinstalacja nie pomogła.


Poprzedni Następny
Wiadomość
Spis treści
From: "Jacek M." <tymkonto_at_nospam_poczta.onet.pl>
Subject: Re: AVR Studio4 - dziwny problem
Date: Wed, 24 May 2006 08:29:43 +0200


Witam.

Pisze sobie programik od jakiegoś czasu w tym środowisku 4.12 Build 472
SP2. Korzystam z kompilatora AVR GCC dostarczanego wraz ze środowiskiem
WinAvr. Pewnego dnia otwieram swój projekt i dostaje komunikaty o błędach:
Error creating plugin.
Jak się okazało, środowisko straciło scieżki do kompilatorów assemblera i
AVR GCC. Kiedy chciałem zrobić nowy projekt nie mogłem wybrać ani ASM ani
GCC project.
Gdzie ustawia się te ścieżki bo nie moge tego odszukać.
Nie wiem właściwie co się mogło stać. Miał ktoś taki problem??
Przeinstalowałem całe środowisko i nic.

Pozdrawiam.
Czy to znaczy, ze ta wersja AVR Studio umozliwia symulacje i debuggowanie
kodu napisanego w C? Jakos tej informacji nie znalazlem w dokumentacji.
Jacek M.



Poprzedni Następny
Wiadomość
Spis treści
From: "T.M.F." <tfrancuz_at_nospam_nospam.mp.pl>
Subject: Re: AVR Studio4 - dziwny problem
Date: Wed, 24 May 2006 10:46:55 +0200


Czy to znaczy, ze ta wersja AVR Studio umozliwia symulacje i debuggowanie
kodu napisanego w C? Jakos tej informacji nie znalazlem w dokumentacji.

Dokladnie tak - umozliwia.

--
Inteligentny dom - http://idom.wizzard.one.pl
Teraz takze forum dyskusyjne
Zobacz, wyslij uwagi, dolacz sie do projektu.

Poprzedni Następny
Wiadomość
Spis treści
From: "Jacek M." <tymkonto_at_nospam_poczta.onet.pl>
Subject: Re: AVR Studio4 - dziwny problem
Date: Wed, 24 May 2006 14:25:22 +0200



Uzytkownik "T.M.F." <tfrancuz_at_nospam_nospam.mp.pl> napisal w wiadomosci
news:a4jdk3-2km.ln1_at_nospam_hermes.wizzard...
Czy to znaczy, ze ta wersja AVR Studio umozliwia symulacje i debuggowanie
kodu napisanego w C? Jakos tej informacji nie znalazlem w dokumentacji.

Dokladnie tak - umozliwia.

Swietnie! Nie wiedzialem o tym.
Pozdrowienia

Jacek M.



Poprzedni Następny
Wiadomość
Spis treści
From: Jurek Szczesiul <jerzy.szczesiul_at_nospam_wycin.ep.com.pl>
Subject: Re: AVR Studio4 - dziwny problem
Date: Wed, 24 May 2006 17:16:52 +0200


Wed, 24 May 2006 08:29:43 +0200, na pl.misc.elektronika, Jacek M.
napisał(a):

Czy to znaczy, ze ta wersja AVR Studio umozliwia symulacje i debuggowanie
kodu napisanego w C? Jakos tej informacji nie znalazlem w dokumentacji.

Cześć

W zakresie oferowanym przez generator informacji debuggera dwarf2
w avr-gcc. Ma on trochę niedoróbek ( pola bitowe, ograniczenie do 64kB )

--
Pozdrowienia
Jurek Szczesiul

Poprzedni Następny
Wiadomość
Spis treści
From: Viki <Viki_at_nospam_wp.pl>
Subject: Re: AVR Studio4 - dziwny problem
Date: Tue, 30 May 2006 08:17:14 +0200


spoko, to był wirus.